I frequently need to look this up and it seems to be against the naming convention of spelling things out.
Other scientific languages do not use that syntax either:
srand
but its deprecated, now uses set.seed()
rng(seed)
random.seed()
While C actually uses srand
, i think we want to improve upon C-Syntax?
Edit: There has been some short discussion about this in 2014
I would also propose reseed!
I prefer something with rand in it. So seedrand
.
Yes, seedrand
seems like a pretty good name.
Unexported Random.seed
?
Since we do have randjump
, why not go with randseed
instead? Other option is to perhaps make them both unexported.
Since we do have randjump, why not go with randseed instead?
I like the increased consistency (but see also bitrand
), although it may sound to some like randseed
would return a random seed, in the same way we have randperm
and randstring
producing random permutations and strings.
That is a good point.
So the choice is between seedrand
and unexported Random.seed
.
I like both, but I think Random.seed
may be the better option:
Random
stands out in the code for readabilityIf anybody wants this in 0.7, it needs to be done ASAP.
Random.seed
can happen if someone makes a PR in the next day, but this is not a release blocker.
Most helpful comment
Unexported
Random.seed
?