Jackett: Can't start Jackett on macOS

Created on 12 Apr 2019  路  14Comments  路  Source: Jackett/Jackett

Here's what i did:
1) Went to macOS Recovery (using Command-R) on my Mac mini (Late 2012), erased/formatted its internal SSD using APFS (non-encrypted), and did a clean install of the latest macOS Mojave (10.14.4) on it.
2) Changed some System Preferences which I believe to be inconsequential to this issue. For example I didn't enable FileVault nor Firewall just in case they were the culprit.
3) Following the macOS install instructions on the front page, I downloaded the latest package, extracted it, and moved the emerged Jackett folder to my home folder.
4) Navigated in Finder to the new /Users/username/Jackett/ folder, right-clicked the install_service_macos script, and selected "Open" (because trying to run it by double-clicking would have only been rejected by macOS Mojave). Then I watched as various black and green lines of text in Terminal said that the installation had been successful. I didn't think to take a note of the exact phrases.
5) I launched Safari and went to the address http://127.0.0.1:9117/ but there was nothing there. Also, according to the list of running processes in Activity Monitor, there is no process called jackett running.
6) I rebooted the computer but that didn't seem to change anything.
7) If I run launchctl load ~/Library/LaunchAgents/org.user.Jackett.plist in Terminal, I get the message /Users/username/Library/LaunchAgents/org.user.Jackett.plist: service already loaded
8) If I run launchctl unload ~/Library/LaunchAgents/org.user.Jackett.plist in Terminal and then cd /Users/username/Jackett/ followed by ./jackett I get the following message:

04-12 19:55:09 Info Starting Jackett v0.11.219.0 

Unhandled Exception: System.Exception: Could not create settings directory. The file '/Users/username/Jackett/Jackett' already exists.
   at Jackett.Common.Services.ConfigurationService.CreateOrMigrateSettings() in /home/appveyor/projects/jackett/src/Jackett.Common/Services/ConfigurationService.cs:line 55
   at Jackett.Server.Program.Main(String[] args) in /home/appveyor/projects/jackett/src/Jackett.Server/Program.cs:line 91
Abort trap: 6
OS MacOS

Most helpful comment

For me, this was a case-sensitivity issue on the filesystem.

There is a collision between the ${jackettdir}/jackett executable and the attempt to create the config folder at ${jackettdir}/Jackett.

To spell it out explicitly:
/usr/local/bin/Jackett/jackett and /usr/local/bin/Jackett/Jackett are the same thing if the filesystem is case insensitive.

When I write code that creates a config folder automatically I use a convention of appending 'Config' or '_config' to make my stuff accidentally-not-break like this.

The default is case-insensitive on a mac so this default config will fail for everyone, it seems. I wonder why there aren't more issues submitted?

I tried looking up a line number for a simple fix but configurationService line 55 points to some boilerplate that reads a .net config and it would take me a lot of .net homework to contribute.

I propose 2 possible fixes:

  • Changed the candidate folder name to 'JackettConfig'
  • Provide a way to specify the config folder name

The first seems simplest since it cares not about case-sensitivity holy wars or the architecture of the rest of the app.

All 14 comments

@flightlevel what do you think is going on here?

Try deleting the /Users/username/Jackett folder
Copy the binaries to any folder EXCEPT '/Users/username/Jackett'. Not a mac user, but /usr/local/bin seems to be an appropriate place for them https://superuser.com/questions/7150/mac-os-x-conventional-places-where-binary-files-should-live
install_service_macos and then see how you go

If that still doesn't work, stop the service. Open a terminal in the Jackett binaries directory and then run ./jackett -t -l and post the full log

First of all, I noticed that what seems to be the exact same issue occurs also on my VirtualBox virtual machine that's running a (pretty much vanilla) macOS Sierra guest. I figured I'd rather do this testing there where I can create a snapshot of the VM and then return back in time to a clean slate. So, I did all the following on the macOS Sierra VM:
1) Extracted (this time a bit newer) package.
2) Moved the emerged Jackett folder to /usr/local/bin
3) Ran the install_service_macos file succesfully. Then observed that Jackett isn't working.
4) Executed launchctl unload ~/Library/LaunchAgents/org.user.Jackett.plist
5) And finally:

cd /usr/local/bin/Jackett/
./jackett -t -l

...which resulted in the following messages:

04-13 13:45:19 Info Starting Jackett v0.11.221.0 
04-13 13:45:19 Info Logging enabled. 
04-13 13:45:20 Info Tracing enabled. 

Unhandled Exception: System.Exception: Could not create settings directory. The file '/usr/local/bin/Jackett/Jackett' already exists.
   at Jackett.Common.Services.ConfigurationService.CreateOrMigrateSettings() in /home/appveyor/projects/jackett/src/Jackett.Common/Services/ConfigurationService.cs:line 55
   at Jackett.Server.Program.Main(String[] args) in /home/appveyor/projects/jackett/src/Jackett.Server/Program.cs:line 91
Abort trap: 6

@tommit @flightlevel as a control, I have followed the same instructions as tommit posted in https://github.com/Jackett/Jackett/issues/5062#issuecomment-482934314, except i am using my win10 VB mojave image, with Jackett 0.11.223, and I had no problems with the service launching and accessing the jackett dashboard via my chrome browser.
Also had no problem unloading the service and running ./jackett via a terminal from /usr/local/bin/Jackett

so it is a puzzle why you are having such trouble ...

I'm completely baffled by this. But I don't crave for a solution anymore since I installed Windows via Boot Camp on my Mac mini, and everything's running fine there.

And now I'm just spitballing, but one thing both my Mac mini (running Mojave) and the VirtualBox VM (running Sierra) have in common is that they're both quite limited in resources - both have just a dual-core cpu and 4GB of RAM. Anyway, here's some of the error messages Jackett keeps throwing every few seconds at the macOS Console on the VM:

There's plenty of these reports under category User Reports that's in the sidebar. They're named like jackett_(date-time)_Sierra.crash:

Process:               jackett [610]
Path:                  /usr/local/bin/Jackett/jackett
Identifier:            jackett
Version:               0
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           jackett [610]
User ID:               501

Date/Time:             2019-04-13 14:31:36.172 +0300
OS Version:            Mac OS X 10.12 (16A323)
Report Version:        12
Anonymous UUID:        86A2FEB1-AAD6-7149-8FB1-CE3881FD257F


Time Awake Since Boot: 1500 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Application Specific Information:
abort() called

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib          0x00007fffba535dda __pthread_kill + 10
1   libsystem_pthread.dylib         0x00007fffba620797 pthread_kill + 90
2   libsystem_c.dylib               0x00007fffba49b440 abort + 129
3   libcoreclr.dylib                0x00000001055d654e PROCAbort + 14
4   libcoreclr.dylib                0x00000001055d50c2 PROCEndProcess(void*, unsigned int, int) + 226
5   libcoreclr.dylib                0x00000001058ad1d1 UnwindManagedExceptionPass1(PAL_SEHException&, _CONTEXT*) + 737
6   libcoreclr.dylib                0x00000001058ad370 DispatchManagedException(PAL_SEHException&, bool) + 304
7   libcoreclr.dylib                0x000000010580e249 IL_Throw(Object*) + 713
8   ???                             0x0000000115b81f8d 0 + 4659355533
9   ???                             0x0000000114665ace 0 + 4637219534
10  libcoreclr.dylib                0x00000001059342a7 CallDescrWorkerInternal + 124
11  libcoreclr.dylib                0x000000010579a471 MethodDescCallSite::CallTargetWorker(unsigned long const*, unsigned long*, int) + 945
12  libcoreclr.dylib                0x000000010566d016 RunMain(MethodDesc*, short, int*, PtrArray**) + 694
13  libcoreclr.dylib                0x000000010566d382 Assembly::ExecuteMainMethod(PtrArray**, int) + 402
14  libcoreclr.dylib                0x00000001056addb4 CorHost2::ExecuteAssembly(unsigned int, char16_t const*, int, char16_t const**, unsigned int*) + 436
15  libcoreclr.dylib                0x00000001055defb6 coreclr_execute_assembly + 230
16  libhostpolicy.dylib             0x0000000105504388 0x10547b000 + 562056
17  libhostpolicy.dylib             0x00000001054ed7df 0x10547b000 + 468959
18  libhostpolicy.dylib             0x00000001054f4089 0x10547b000 + 495753
19  libhostfxr.dylib                0x00000001054168a3 0x10538c000 + 567459
20  libhostfxr.dylib                0x00000001054365ee 0x10538c000 + 697838
21  libhostfxr.dylib                0x00000001054391c2 0x10538c000 + 709058
22  libhostfxr.dylib                0x0000000105437678 0x10538c000 + 702072
23  libhostfxr.dylib                0x0000000105417919 0x10538c000 + 571673
24  jackett                         0x000000010533ddd4 0x105330000 + 56788
25  jackett                         0x000000010533e3a5 0x105330000 + 58277
26  libdyld.dylib                   0x00007fffba407255 start + 1

Thread 1:
0   libsystem_kernel.dylib          0x00007fffba52e41a mach_msg_trap + 10
1   libsystem_kernel.dylib          0x00007fffba52d867 mach_msg + 55
2   libcoreclr.dylib                0x00000001055db838 MachMessage::Receive(unsigned int) + 72
3   libcoreclr.dylib                0x00000001055da78e SEHExceptionThread(void*) + 94
4   libsystem_pthread.dylib         0x00007fffba61dabb _pthread_body + 180
5   libsystem_pthread.dylib         0x00007fffba61da07 _pthread_start + 286
6   libsystem_pthread.dylib         0x00007fffba61d231 thread_start + 13

Thread 2:
0   libsystem_kernel.dylib          0x00007fffba537236 poll + 10
1   libcoreclr.dylib                0x00000001055cddde CorUnix::CPalSynchronizationManager::ThreadPrepareForShutdown() + 30
2   libcoreclr.dylib                0x00000001055cf910 CorUnix::CPalSynchronizationManager::WorkerThread(void*) + 944
3   libcoreclr.dylib                0x00000001055d8188 CorUnix::CPalThread::ThreadEntry(void*) + 328
4   libsystem_pthread.dylib         0x00007fffba61dabb _pthread_body + 180
5   libsystem_pthread.dylib         0x00007fffba61da07 _pthread_start + 286
6   libsystem_pthread.dylib         0x00007fffba61d231 thread_start + 13

Thread 3:
0   libsystem_kernel.dylib          0x00007fffba535ad6 __open + 10
1   libcoreclr.dylib                0x000000010564b33f TwoWayPipe::WaitForConnection() + 31
2   libcoreclr.dylib                0x0000000105642d5f DbgTransportSession::TransportWorker() + 159
3   libcoreclr.dylib                0x00000001056416b9 DbgTransportSession::TransportWorkerStatic(void*) + 9
4   libcoreclr.dylib                0x00000001055d8188 CorUnix::CPalThread::ThreadEntry(void*) + 328
5   libsystem_pthread.dylib         0x00007fffba61dabb _pthread_body + 180
6   libsystem_pthread.dylib         0x00007fffba61da07 _pthread_start + 286
7   libsystem_pthread.dylib         0x00007fffba61d231 thread_start + 13

Thread 4:
0   libsystem_kernel.dylib          0x00007fffba535c8a __psynch_cvwait + 10
1   libsystem_pthread.dylib         0x00007fffba61e97a _pthread_cond_wait + 712
2   libcoreclr.dylib                0x00000001055cdad2 CorUnix::CPalSynchronizationManager::ThreadNativeWait(CorUnix::_ThreadNativeWaitData*, unsigned int, CorUnix::ThreadWakeupReason*, unsigned int*) + 338
3   libcoreclr.dylib                0x00000001055cd6e7 CorUnix::CPalSynchronizationManager::BlockThread(CorUnix::CPalThread*, unsigned int, bool, bool, CorUnix::ThreadWakeupReason*, unsigned int*) + 375
4   libcoreclr.dylib                0x00000001055d2063 CorUnix::InternalWaitForMultipleObjectsEx(CorUnix::CPalThread*, unsigned int, void* const*, int, unsigned int, int, int) + 1891
5   libcoreclr.dylib                0x00000001055d22f2 WaitForMultipleObjectsEx + 82
6   libcoreclr.dylib                0x000000010563fb08 DebuggerRCThread::MainLoop() + 264
7   libcoreclr.dylib                0x000000010563f99b DebuggerRCThread::ThreadProc() + 251
8   libcoreclr.dylib                0x000000010563f6a4 DebuggerRCThread::ThreadProcStatic(void*) + 132
9   libcoreclr.dylib                0x00000001055d8188 CorUnix::CPalThread::ThreadEntry(void*) + 328
10  libsystem_pthread.dylib         0x00007fffba61dabb _pthread_body + 180
11  libsystem_pthread.dylib         0x00007fffba61da07 _pthread_start + 286
12  libsystem_pthread.dylib         0x00007fffba61d231 thread_start + 13

Thread 5:
0   libsystem_kernel.dylib          0x00007fffba535c8a __psynch_cvwait + 10
1   libsystem_pthread.dylib         0x00007fffba61e97a _pthread_cond_wait + 712
2   libcoreclr.dylib                0x00000001055cdad2 CorUnix::CPalSynchronizationManager::ThreadNativeWait(CorUnix::_ThreadNativeWaitData*, unsigned int, CorUnix::ThreadWakeupReason*, unsigned int*) + 338
3   libcoreclr.dylib                0x00000001055cd6e7 CorUnix::CPalSynchronizationManager::BlockThread(CorUnix::CPalThread*, unsigned int, bool, bool, CorUnix::ThreadWakeupReason*, unsigned int*) + 375
4   libcoreclr.dylib                0x00000001055d2063 CorUnix::InternalWaitForMultipleObjectsEx(CorUnix::CPalThread*, unsigned int, void* const*, int, unsigned int, int, int) + 1891
5   libcoreclr.dylib                0x00000001055d222d WaitForSingleObjectEx + 77
6   libcoreclr.dylib                0x000000010587b5fe CLREventBase::WaitEx(unsigned int, WaitMode, PendingSync*) + 206
7   libcoreclr.dylib                0x00000001058c7683 SVR::gc_heap::gc_thread_function() + 163
8   libcoreclr.dylib                0x00000001058c75df SVR::gc_heap::gc_thread_stub(void*) + 79
9   libcoreclr.dylib                0x00000001057e7fa8 (anonymous namespace)::CreateNonSuspendableThread(void (*)(void*), void*, char const*)::$_1::__invoke(void*) + 168
10  libcoreclr.dylib                0x00000001055d8188 CorUnix::CPalThread::ThreadEntry(void*) + 328
11  libsystem_pthread.dylib         0x00007fffba61dabb _pthread_body + 180
12  libsystem_pthread.dylib         0x00007fffba61da07 _pthread_start + 286
13  libsystem_pthread.dylib         0x00007fffba61d231 thread_start + 13

Thread 6:
0   libsystem_kernel.dylib          0x00007fffba535c8a __psynch_cvwait + 10
1   libsystem_pthread.dylib         0x00007fffba61e97a _pthread_cond_wait + 712
2   libcoreclr.dylib                0x00000001055cdad2 CorUnix::CPalSynchronizationManager::ThreadNativeWait(CorUnix::_ThreadNativeWaitData*, unsigned int, CorUnix::ThreadWakeupReason*, unsigned int*) + 338
3   libcoreclr.dylib                0x00000001055cd6e7 CorUnix::CPalSynchronizationManager::BlockThread(CorUnix::CPalThread*, unsigned int, bool, bool, CorUnix::ThreadWakeupReason*, unsigned int*) + 375
4   libcoreclr.dylib                0x00000001055d2063 CorUnix::InternalWaitForMultipleObjectsEx(CorUnix::CPalThread*, unsigned int, void* const*, int, unsigned int, int, int) + 1891
5   libcoreclr.dylib                0x00000001055d222d WaitForSingleObjectEx + 77
6   libcoreclr.dylib                0x000000010587b5fe CLREventBase::WaitEx(unsigned int, WaitMode, PendingSync*) + 206
7   libcoreclr.dylib                0x00000001058c7661 SVR::gc_heap::gc_thread_function() + 129
8   libcoreclr.dylib                0x00000001058c75df SVR::gc_heap::gc_thread_stub(void*) + 79
9   libcoreclr.dylib                0x00000001057e7fa8 (anonymous namespace)::CreateNonSuspendableThread(void (*)(void*), void*, char const*)::$_1::__invoke(void*) + 168
10  libcoreclr.dylib                0x00000001055d8188 CorUnix::CPalThread::ThreadEntry(void*) + 328
11  libsystem_pthread.dylib         0x00007fffba61dabb _pthread_body + 180
12  libsystem_pthread.dylib         0x00007fffba61da07 _pthread_start + 286
13  libsystem_pthread.dylib         0x00007fffba61d231 thread_start + 13

Thread 7:
0   libsystem_kernel.dylib          0x00007fffba535c8a __psynch_cvwait + 10
1   libsystem_pthread.dylib         0x00007fffba61e97a _pthread_cond_wait + 712
2   libcoreclr.dylib                0x00000001055cda95 CorUnix::CPalSynchronizationManager::ThreadNativeWait(CorUnix::_ThreadNativeWaitData*, unsigned int, CorUnix::ThreadWakeupReason*, unsigned int*) + 277
3   libcoreclr.dylib                0x00000001055cd6e7 CorUnix::CPalSynchronizationManager::BlockThread(CorUnix::CPalThread*, unsigned int, bool, bool, CorUnix::ThreadWakeupReason*, unsigned int*) + 375
4   libcoreclr.dylib                0x00000001055d2063 CorUnix::InternalWaitForMultipleObjectsEx(CorUnix::CPalThread*, unsigned int, void* const*, int, unsigned int, int, int) + 1891
5   libcoreclr.dylib                0x00000001055d222d WaitForSingleObjectEx + 77
6   libcoreclr.dylib                0x000000010587b5fe CLREventBase::WaitEx(unsigned int, WaitMode, PendingSync*) + 206
7   libcoreclr.dylib                0x00000001057e46ef FinalizerThread::WaitForFinalizerEvent(CLREvent*) + 31
8   libcoreclr.dylib                0x00000001057e4863 FinalizerThread::FinalizerThreadWorker(void*) + 115
9   libcoreclr.dylib                0x000000010575de33 ManagedThreadBase_DispatchOuter(ManagedThreadCallState*) + 419
10  libcoreclr.dylib                0x000000010575e4d9 ManagedThreadBase::FinalizerBase(void (*)(void*)) + 73
11  libcoreclr.dylib                0x00000001057e4b7c FinalizerThread::FinalizerThreadStart(void*) + 204
12  libcoreclr.dylib                0x00000001055d8188 CorUnix::CPalThread::ThreadEntry(void*) + 328
13  libsystem_pthread.dylib         0x00007fffba61dabb _pthread_body + 180
14  libsystem_pthread.dylib         0x00007fffba61da07 _pthread_start + 286
15  libsystem_pthread.dylib         0x00007fffba61d231 thread_start + 13

Thread 8:
0   libsystem_kernel.dylib          0x00007fffba52e41a mach_msg_trap + 10
1   libsystem_kernel.dylib          0x00007fffba52d867 mach_msg + 55
2   libclrjit.dylib                 0x000000010b4d1d58 MachMessage::Receive(unsigned int) + 72
3   libclrjit.dylib                 0x000000010b4d0cae SEHExceptionThread(void*) + 94
4   libsystem_pthread.dylib         0x00007fffba61dabb _pthread_body + 180
5   libsystem_pthread.dylib         0x00007fffba61da07 _pthread_start + 286
6   libsystem_pthread.dylib         0x00007fffba61d231 thread_start + 13

Thread 9:
0   libsystem_kernel.dylib          0x00007fffba535c8a __psynch_cvwait + 10
1   libsystem_pthread.dylib         0x00007fffba61e97a _pthread_cond_wait + 712
2   libcoreclr.dylib                0x00000001055cda95 CorUnix::CPalSynchronizationManager::ThreadNativeWait(CorUnix::_ThreadNativeWaitData*, unsigned int, CorUnix::ThreadWakeupReason*, unsigned int*) + 277
3   libcoreclr.dylib                0x00000001055cd6e7 CorUnix::CPalSynchronizationManager::BlockThread(CorUnix::CPalThread*, unsigned int, bool, bool, CorUnix::ThreadWakeupReason*, unsigned int*) + 375
4   libcoreclr.dylib                0x00000001055d26ed SleepEx + 141
5   libcoreclr.dylib                0x0000000105780c26 ThreadpoolMgr::TimerThreadFire() + 150
6   libcoreclr.dylib                0x0000000105780af5 ThreadpoolMgr::TimerThreadStart(void*) + 181
7   libcoreclr.dylib                0x00000001055d8188 CorUnix::CPalThread::ThreadEntry(void*) + 328
8   libsystem_pthread.dylib         0x00007fffba61dabb _pthread_body + 180
9   libsystem_pthread.dylib         0x00007fffba61da07 _pthread_start + 286
10  libsystem_pthread.dylib         0x00007fffba61d231 thread_start + 13

Thread 0 crashed with X86 Thread State (64-bit):
  rax: 0x0000000000000000  rbx: 0x0000000000000006  rcx: 0x00007fff5a8c4f58  rdx: 0x0000000000000000
  rdi: 0x000000000000150b  rsi: 0x0000000000000006  rbp: 0x00007fff5a8c4f80  rsp: 0x00007fff5a8c4f58
   r8: 0x00007fd80c806100   r9: 0x0000000000008d76  r10: 0x0000000008000000  r11: 0x0000000000000206
  r12: 0x00007fff5a8c55a0  r13: 0x0000000000000000  r14: 0x00007fffc310a3c0  r15: 0x0000000000000000
  rip: 0x00007fffba535dda  rfl: 0x0000000000000206  cr2: 0x00007000001e8ff8

Logical CPU:     0
Error Code:      0x02000005
Trap Number:     133


Binary Images:
       0x105330000 -        0x105353ff7 +jackett (0) <136F22DB-9DE4-361D-B7B6-E0D9538CC346> /usr/local/bin/Jackett/jackett
       0x10538c000 -        0x105472fff +libhostfxr.dylib (0) <C49DB0F3-1732-3BD6-9C91-2A1DCF1393DD> /usr/local/bin/Jackett/libhostfxr.dylib
       0x10547b000 -        0x105564fff +libhostpolicy.dylib (0) <8EB6567B-8D4D-3DEA-9D69-37893B721932> /usr/local/bin/Jackett/libhostpolicy.dylib
       0x105593000 -        0x105ae4fff +libcoreclr.dylib (0) <6585AFE2-74DA-3220-968D-F8952E2F870B> /usr/local/bin/Jackett/libcoreclr.dylib
       0x10b309000 -        0x10b519ff7 +libclrjit.dylib (0) <7A969A5B-DFCC-3B9D-AEBB-0B6E625067B7> /usr/local/bin/Jackett/libclrjit.dylib
       0x10b5bd000 -        0x10b5c8fff +System.Globalization.Native.dylib (0) <AFD4F78C-6D67-398B-91F1-92909DAA9254> /usr/local/bin/Jackett/System.Globalization.Native.dylib
       0x10cf4b000 -        0x10cf53fff +System.Native.dylib (0) <788FC709-5EE4-307D-9E29-13E896051F66> /usr/local/bin/Jackett/System.Native.dylib
       0x110dca000 -        0x110e071c7  dyld (421.1) <A525EAEA-AF86-30C2-B360-3D093B4F0828> /usr/lib/dyld
    0x7fffa1e4a000 -     0x7fffa1e4afff  com.apple.Accelerate (1.11 - Accelerate 1.11) <BDDB2053-BB24-34E4-A452-50D1260BF672> /System/Library/Frameworks/Accelerate.framework/Versions/A/Accelerate
    0x7fffa1e63000 -     0x7fffa24a3fe3  com.apple.vImage (8.1 - ???) <6CC22156-EC5C-3DC3-8132-41376F090B08> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vImage.framework/Versions/A/vImage
    0x7fffa24a4000 -     0x7fffa266bfef  libBLAS.dylib (1185) <0D55CF73-6DBD-3D15-B500-189479638551> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib
    0x7fffa266c000 -     0x7fffa2683fff  libBNNS.dylib (14) <43A9B06E-3C21-3CE6-B0C1-99DA172DEEB0> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBNNS.dylib
    0x7fffa2684000 -     0x7fffa2a8ffff  libLAPACK.dylib (1185) <E7AE9C48-6E42-3EB7-A257-D48E0CB48D00> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libLAPACK.dylib
    0x7fffa2a90000 -     0x7fffa2aa6fff  libLinearAlgebra.dylib (1185) <08F00EFB-B477-3421-906E-3D364E607E6A> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libLinearAlgebra.dylib
    0x7fffa2aa7000 -     0x7fffa2aadfff  libQuadrature.dylib (3) <120F6228-A3D4-3184-89D7-785ADC2AC715> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libQuadrature.dylib
    0x7fffa2aae000 -     0x7fffa2ac1ff7  libSparseBLAS.dylib (1185) <912E3D25-27C0-3245-B64C-3CAD43A5D633> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libSparseBLAS.dylib
    0x7fffa2ac2000 -     0x7fffa2c0fff7  libvDSP.dylib (600) <87EF1D0A-1F85-31DD-AD8F-AB31E7D8E73B> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libvDSP.dylib
    0x7fffa2c10000 -     0x7fffa2cc7fff  libvMisc.dylib (600) <F6EA539E-0A90-3F8A-9ECA-001E46394E29> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libvMisc.dylib
    0x7fffa2cc8000 -     0x7fffa2cc8fff  com.apple.Accelerate.vecLib (3.11 - vecLib 3.11) <B4B785D8-CB43-3E5D-AE81-1F27885AA112> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/vecLib
    0x7fffa3c6e000 -     0x7fffa3c6efff  com.apple.ApplicationServices (48 - 48) <3E1395EA-C661-3318-9B87-9857BB81021B> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices
    0x7fffa3c6f000 -     0x7fffa3cddff7  com.apple.ApplicationServices.ATS (377 - 422) <521E41BF-D495-3233-B6BF-C0B83DD1A8C0> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ATS.framework/Versions/A/ATS
    0x7fffa3d77000 -     0x7fffa3ea5fff  libFontParser.dylib (194) <CDC6A0AA-E6AC-315B-AFBF-011F64548911> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ATS.framework/Versions/A/Resources/libFontParser.dylib
    0x7fffa3ea6000 -     0x7fffa3ef0fff  libFontRegistry.dylib (196) <3B8B0E78-2B30-3F18-B7D3-BE4E96F6BAF3> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ATS.framework/Versions/A/Resources/libFontRegistry.dylib
    0x7fffa3feb000 -     0x7fffa4095ff7  com.apple.ColorSync (4.12.0 - 502) <C86F8032-83DD-34EB-A4CB-87E96F25CF1C> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ColorSync.framework/Versions/A/ColorSync
    0x7fffa4096000 -     0x7fffa40e6fff  com.apple.HIServices (1.22 - 589) <3167EF9C-F121-39EF-AAE2-7700E7128426> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/HIServices.framework/Versions/A/HIServices
    0x7fffa40e7000 -     0x7fffa40f6ff3  com.apple.LangAnalysis (1.7.0 - 1.7.0) <47D1A017-91A4-37F3-93E0-3923CD6ED2DE> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/LangAnalysis.framework/Versions/A/LangAnalysis
    0x7fffa40f7000 -     0x7fffa4144fff  com.apple.print.framework.PrintCore (12 - 491) <B7CC15C1-AF50-37F3-8AF6-65F8CDC323F0> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/PrintCore.framework/Versions/A/PrintCore
    0x7fffa4145000 -     0x7fffa4180fff  com.apple.QD (3.12 - 310) <8F718290-DD82-36CE-9AF0-EFB6D31A49F4> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/QD.framework/Versions/A/QD
    0x7fffa4181000 -     0x7fffa418cff7  com.apple.speech.synthesis.framework (6.0.15 - 6.0.15) <23EA6076-ECDF-3A50-81E7-3CE6451DC8C4> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/SpeechSynthesis.framework/Versions/A/SpeechSynthesis
    0x7fffa418d000 -     0x7fffa4399fff  com.apple.audio.toolbox.AudioToolbox (1.14 - 1.14) <EDDC86C8-92F3-34C6-A5C1-A176ADA724C3> /System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox
    0x7fffa4503000 -     0x7fffa4886fff  com.apple.CFNetwork (807.0.4 - 807.0.4) <A338A213-4FFF-3317-B4DB-84735C63C507> /System/Library/Frameworks/CFNetwork.framework/Versions/A/CFNetwork
    0x7fffa4e84000 -     0x7fffa4f14ff7  com.apple.audio.CoreAudio (4.3.0 - 4.3.0) <0352D931-596B-3AFE-B5C6-5925CF9F870E> /System/Library/Frameworks/CoreAudio.framework/Versions/A/CoreAudio
    0x7fffa4f29000 -     0x7fffa5223fff  com.apple.CoreData (120 - 752.2) <51AB540E-01AE-3207-8DE5-3E912FA9B5DF> /System/Library/Frameworks/CoreData.framework/Versions/A/CoreData
    0x7fffa52b1000 -     0x7fffa5744ff7  com.apple.CoreFoundation (6.9 - 1348.1) <2A35BE4F-BA5B-3C22-BCF1-CFBBA2786081> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
    0x7fffa5745000 -     0x7fffa5de5ff7  com.apple.CoreGraphics (2.0 - 1070) <765D6A92-48AE-3CBB-9967-61300D715F1F> /System/Library/Frameworks/CoreGraphics.framework/Versions/A/CoreGraphics
    0x7fffa6180000 -     0x7fffa6180fff  com.apple.CoreServices (775.8 - 775.8) <C36F7F47-D585-32F2-8A6F-7711935CDFD6> /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices
    0x7fffa6181000 -     0x7fffa61d2ff7  com.apple.AE (712 - 712) <0EF17D7E-6BA4-3555-BC38-9BD0CC5B82A3> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/AE.framework/Versions/A/AE
    0x7fffa61d3000 -     0x7fffa64aefff  com.apple.CoreServices.CarbonCore (1159 - 1159) <837B7ECF-7E62-3210-988C-63D7AB4EAA88> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CarbonCore.framework/Versions/A/CarbonCore
    0x7fffa64af000 -     0x7fffa64e2fff  com.apple.DictionaryServices (1.2 - 274) <302B8678-D057-3CF8-ACA7-7424A4A6A00A> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/DictionaryServices.framework/Versions/A/DictionaryServices
    0x7fffa64e3000 -     0x7fffa64ebffb  com.apple.CoreServices.FSEvents (1230 - 1230) <8836E7D0-844F-36F9-9601-B630BB82336B> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/FSEvents.framework/Versions/A/FSEvents
    0x7fffa64ec000 -     0x7fffa6657fff  com.apple.LaunchServices (775.8 - 775.8) <6E7CE1DA-27A4-3B48-A8E3-F2AA868ADD7C> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/LaunchServices
    0x7fffa6658000 -     0x7fffa6708ffb  com.apple.Metadata (10.7.0 - 1075) <9EDF10CF-1755-346A-A3C9-97642C443A58> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/Metadata.framework/Versions/A/Metadata
    0x7fffa6709000 -     0x7fffa6768fff  com.apple.CoreServices.OSServices (775.8 - 775.8) <FCF1334F-D2D7-3C5A-A8FE-C173C5EDE586> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServices.framework/Versions/A/OSServices
    0x7fffa6769000 -     0x7fffa67d9fff  com.apple.SearchKit (1.4.0 - 1.4.0) <F1B3EF8D-E820-317C-AC7F-8F056C246874> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/SearchKit.framework/Versions/A/SearchKit
    0x7fffa67da000 -     0x7fffa6820ff7  com.apple.coreservices.SharedFileList (38 - 38) <6C5A3FBB-9502-3725-AC3A-AE7B1528BBD4> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/SharedFileList.framework/Versions/A/SharedFileList
    0x7fffa68ad000 -     0x7fffa69f8ff7  com.apple.CoreText (352.0 - 544) <064B53E8-CD5A-3D1B-81DF-498A659FC20A> /System/Library/Frameworks/CoreText.framework/Versions/A/CoreText
    0x7fffa6b9b000 -     0x7fffa6ba0fff  com.apple.DiskArbitration (2.7 - 2.7) <566D5C06-13E8-3638-B2EC-2B834D5F04F1> /System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration
    0x7fffa6d2f000 -     0x7fffa70d6ffb  com.apple.Foundation (6.9 - 1349) <08A463B1-296E-3AC1-B8D3-01A75B0785A8> /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation
    0x7fffa7102000 -     0x7fffa7133ff3  com.apple.GSS (4.0 - 2.0) <B30A0B99-AFDE-3BF8-A04F-761A75A6A3B1> /System/Library/Frameworks/GSS.framework/Versions/A/GSS
    0x7fffa728b000 -     0x7fffa7320fff  com.apple.framework.IOKit (2.0.2 - 1324.1.7) <10BDCD1E-0463-3C53-BF11-C9A0919C1588> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit
    0x7fffa7321000 -     0x7fffa7327ffb  com.apple.IOSurface (152 - 152) <558D4451-2D9D-3D47-B3A5-E7C18DF53F1B> /System/Library/Frameworks/IOSurface.framework/Versions/A/IOSurface
    0x7fffa737b000 -     0x7fffa74d4ff7  com.apple.ImageIO.framework (3.3.0 - 1570.1) <6B0177F3-A7BE-30D7-B075-7117E2C28A5F> /System/Library/Frameworks/ImageIO.framework/Versions/A/ImageIO
    0x7fffa74d5000 -     0x7fffa74d9fff  libGIF.dylib (1570.1) <AE06146E-C4B3-3088-B6BC-569DDFCD8D77> /System/Library/Frameworks/ImageIO.framework/Versions/A/Resources/libGIF.dylib
    0x7fffa74da000 -     0x7fffa75cbfff  libJP2.dylib (1570.1) <6D268C9D-309B-3098-BBCF-8A1B98DBBEE9> /System/Library/Frameworks/ImageIO.framework/Versions/A/Resources/libJP2.dylib
    0x7fffa75cc000 -     0x7fffa75effff  libJPEG.dylib (1570.1) <7EFA7A91-06C8-329E-AA3D-CF6DB2220A5A> /System/Library/Frameworks/ImageIO.framework/Versions/A/Resources/libJPEG.dylib
    0x7fffa75f0000 -     0x7fffa7616fff  libPng.dylib (1570.1) <AF8292B6-2564-30D4-8860-6B0C9D0E1405> /System/Library/Frameworks/ImageIO.framework/Versions/A/Resources/libPng.dylib
    0x7fffa7617000 -     0x7fffa7619ff3  libRadiance.dylib (1570.1) <B0256EB7-7F87-39FD-BD35-83577F4FE7EC> /System/Library/Frameworks/ImageIO.framework/Versions/A/Resources/libRadiance.dylib
    0x7fffa761a000 -     0x7fffa7673fff  libTIFF.dylib (1570.1) <F1F0B7C6-388F-35E4-87CF-816CEE8B0E00> /System/Library/Frameworks/ImageIO.framework/Versions/A/Resources/libTIFF.dylib
    0x7fffa823a000 -     0x7fffa8253ff7  com.apple.Kerberos (3.0 - 1) <49DCBE1A-130C-3FBF-AAEA-AF9A518913AC> /System/Library/Frameworks/Kerberos.framework/Versions/A/Kerberos
    0x7fffa91a4000 -     0x7fffa91acfff  com.apple.NetFS (6.0 - 4.0) <6614F9B8-0861-338B-8FF0-8E402F96141C> /System/Library/Frameworks/NetFS.framework/Versions/A/NetFS
    0x7fffa95a0000 -     0x7fffa95b9ffb  com.apple.CFOpenDirectory (10.12 - 194) <BDD22B3E-4149-366A-A974-942280861DD4> /System/Library/Frameworks/OpenDirectory.framework/Versions/A/Frameworks/CFOpenDirectory.framework/Versions/A/CFOpenDirectory
    0x7fffa95ba000 -     0x7fffa95c5ff7  com.apple.OpenDirectory (10.12 - 194) <E1125140-E42C-369C-8DC8-D0935767B275> /System/Library/Frameworks/OpenDirectory.framework/Versions/A/OpenDirectory
    0x7fffab5c1000 -     0x7fffab8dcfff  com.apple.security (7.0 - 57740.1.18) <AF5E42F1-B513-3410-A5BE-1EC9CBAF8452> /System/Library/Frameworks/Security.framework/Versions/A/Security
    0x7fffab8dd000 -     0x7fffab953ff7  com.apple.securityfoundation (6.0 - 55132.1.1) <259D4B70-0F8C-3818-99E7-3EBEAA18DE1B> /System/Library/Frameworks/SecurityFoundation.framework/Versions/A/SecurityFoundation
    0x7fffab97d000 -     0x7fffab980ff3  com.apple.xpc.ServiceManagement (1.0 - 1) <6A9EA339-BB6A-3DD9-BF08-00B8C0262839> /System/Library/Frameworks/ServiceManagement.framework/Versions/A/ServiceManagement
    0x7fffabd05000 -     0x7fffabd76ff7  com.apple.SystemConfiguration (1.14 - 1.14) <C7F21776-2CCE-327B-B155-7A5948277BD6> /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfiguration
    0x7fffae4c8000 -     0x7fffae55397f  com.apple.AppleJPEG (1.0 - 1) <B4C3209B-58A5-359F-A898-F61B6C40E5E9> /System/Library/PrivateFrameworks/AppleJPEG.framework/Versions/A/AppleJPEG
    0x7fffaff4e000 -     0x7fffaff57ffb  com.apple.CommonAuth (4.0 - 2.0) <D9958C57-9E97-33F5-A21C-B454FDB11548> /System/Library/PrivateFrameworks/CommonAuth.framework/Versions/A/CommonAuth
    0x7fffb0673000 -     0x7fffb0684fff  com.apple.CoreEmoji (1.0 - 40) <F3D73BF8-6D48-3B1F-BBE6-EE927E725E92> /System/Library/PrivateFrameworks/CoreEmoji.framework/Versions/A/CoreEmoji
    0x7fffb35f1000 -     0x7fffb3667fff  com.apple.Heimdal (4.0 - 2.0) <18C127D7-9C61-3C5B-8C6F-7953760D2674> /System/Library/PrivateFrameworks/Heimdal.framework/Versions/A/Heimdal
    0x7fffb3d9b000 -     0x7fffb3f4ffff  com.apple.LanguageModeling (1.0 - 123) <10152D7F-C7C0-34AA-A295-D712D16C76E6> /System/Library/PrivateFrameworks/LanguageModeling.framework/Versions/A/LanguageModeling
    0x7fffb49df000 -     0x7fffb4a05fff  com.apple.MultitouchSupport.framework (367.6 - 367.6) <32D8588A-29BD-3A23-92B2-05C013DA5BC5> /System/Library/PrivateFrameworks/MultitouchSupport.framework/Versions/A/MultitouchSupport
    0x7fffb4ab2000 -     0x7fffb4abcfff  com.apple.NetAuth (6.0 - 6.0) <D57D5888-0290-3295-A1C4-D673D4DCB497> /System/Library/PrivateFrameworks/NetAuth.framework/Versions/A/NetAuth
    0x7fffb766e000 -     0x7fffb7674ff7  com.apple.TCC (1.0 - 1) <CEE9F9F9-2A24-3F60-BE73-4703D85E307C> /System/Library/PrivateFrameworks/TCC.framework/Versions/A/TCC
    0x7fffb8ac1000 -     0x7fffb8ac3ffb  com.apple.loginsupport (1.0 - 1) <03B57D6F-C210-32BC-B384-5B0E95660283> /System/Library/PrivateFrameworks/login.framework/Versions/A/Frameworks/loginsupport.framework/Versions/A/loginsupport
    0x7fffb8b18000 -     0x7fffb8b33ff7  libCRFSuite.dylib (34) <BACC371B-6153-36B5-BC54-3BCF26FBB221> /usr/lib/libCRFSuite.dylib
    0x7fffb8b34000 -     0x7fffb8b3ffff  libChineseTokenizer.dylib (21) <09E74E18-ADB2-30D2-A858-13691CB1186C> /usr/lib/libChineseTokenizer.dylib
    0x7fffb8bd1000 -     0x7fffb8bd2ff3  libDiagnosticMessagesClient.dylib (102) <422911A4-E273-3E88-BFC4-DF6470E48242> /usr/lib/libDiagnosticMessagesClient.dylib
    0x7fffb8e0a000 -     0x7fffb8e0afff  libOpenScriptingUtil.dylib (172) <D025E180-BB3B-3FFA-98FC-B6835354D723> /usr/lib/libOpenScriptingUtil.dylib
    0x7fffb8e0f000 -     0x7fffb8e10ff3  libSystem.B.dylib (1238) <168B3C56-081B-3998-9A44-681EB4C6828F> /usr/lib/libSystem.B.dylib
    0x7fffb8e7c000 -     0x7fffb8ea7ffb  libarchive.2.dylib (41.1.1) <C4F76D18-8484-3779-AE80-14F27E57ABB5> /usr/lib/libarchive.2.dylib
    0x7fffb8f86000 -     0x7fffb8f86ff3  libauto.dylib (187) <5BBF6A00-CC76-389D-84E7-CA88EDADE683> /usr/lib/libauto.dylib
    0x7fffb8f87000 -     0x7fffb8f97ff3  libbsm.0.dylib (34) <20084796-B04D-3B35-A003-EA11459557A9> /usr/lib/libbsm.0.dylib
    0x7fffb8f98000 -     0x7fffb8fa6ff7  libbz2.1.0.dylib (38) <6FD3B63F-0F86-3A25-BD5B-E243F58792C9> /usr/lib/libbz2.1.0.dylib
    0x7fffb8fa7000 -     0x7fffb8ffdff7  libc++.1.dylib (307.4) <BEE86868-F831-384C-919E-2B286ACFE87C> /usr/lib/libc++.1.dylib
    0x7fffb8ffe000 -     0x7fffb9028fff  libc++abi.dylib (307.2) <1CEF8ABB-7E6D-3C2F-8E0A-E7884478DD23> /usr/lib/libc++abi.dylib
    0x7fffb9029000 -     0x7fffb9039ffb  libcmph.dylib (6) <2B5D405E-2D0B-3320-ABD6-622934C86ABE> /usr/lib/libcmph.dylib
    0x7fffb903a000 -     0x7fffb904fffb  libcompression.dylib (34) <AEF908E6-C0FE-3884-BD45-FB37A035545D> /usr/lib/libcompression.dylib
    0x7fffb9050000 -     0x7fffb9050ff7  libcoretls.dylib (121.1.1) <F3BAB54C-DA82-37C3-A218-46FEB179D555> /usr/lib/libcoretls.dylib
    0x7fffb9051000 -     0x7fffb9052ffb  libcoretls_cfhelpers.dylib (121.1.1) <D12709F3-BBE3-3CF7-9070-C2A0803F5526> /usr/lib/libcoretls_cfhelpers.dylib
    0x7fffb938e000 -     0x7fffb93e1ff7  libcups.2.dylib (450) <04CA1F55-4B70-3D65-B4B1-62F6C271A9EF> /usr/lib/libcups.2.dylib
    0x7fffb945b000 -     0x7fffb945bfff  libenergytrace.dylib (15) <A1B040A2-7977-3097-9ADF-34FF181EB970> /usr/lib/libenergytrace.dylib
    0x7fffb946b000 -     0x7fffb9470ff3  libheimdal-asn1.dylib (498) <8F3F1AE8-CE4A-355C-82E3-74DA46B5BB02> /usr/lib/libheimdal-asn1.dylib
    0x7fffb9471000 -     0x7fffb9563ff7  libiconv.2.dylib (50) <42125B35-81D7-3FC4-9475-A26DBE10884D> /usr/lib/libiconv.2.dylib
    0x7fffb9564000 -     0x7fffb9789fff  libicucore.A.dylib (57131.0.1) <72594943-D25E-3F70-A4AC-8E9F9F442B7E> /usr/lib/libicucore.A.dylib
    0x7fffb978f000 -     0x7fffb9790fff  liblangid.dylib (126) <3F4530C9-8BE1-3AA7-9A82-98694D240866> /usr/lib/liblangid.dylib
    0x7fffb9791000 -     0x7fffb97aaffb  liblzma.5.dylib (10) <44BD0279-99DD-36B5-8A6E-C11432E2098D> /usr/lib/liblzma.5.dylib
    0x7fffb97ab000 -     0x7fffb97c1ff7  libmarisa.dylib (5) <2183D484-032D-3DE5-8984-3A14006E034E> /usr/lib/libmarisa.dylib
    0x7fffb97c2000 -     0x7fffb9a6bfff  libmecabra.dylib (744) <545EDC2D-22BB-3E8F-BFD3-921447581D9F> /usr/lib/libmecabra.dylib
    0x7fffb9a9e000 -     0x7fffb9b16ffb  libnetwork.dylib (856.1.8) <30FC3C60-CCA9-3E2B-80AA-DE53F5762374> /usr/lib/libnetwork.dylib
    0x7fffb9b17000 -     0x7fffb9eec127  libobjc.A.dylib (706) <47104A1B-13E8-369F-BC36-27FF465809FD> /usr/lib/libobjc.A.dylib
    0x7fffb9eef000 -     0x7fffb9ef3fff  libpam.2.dylib (21) <352F8FF6-2248-3594-B357-8D031DEFB06C> /usr/lib/libpam.2.dylib
    0x7fffb9ef4000 -     0x7fffb9f24ff7  libpcap.A.dylib (67) <450DB888-2C0C-3085-A5F1-69324DFE902C> /usr/lib/libpcap.A.dylib
    0x7fffb9f42000 -     0x7fffb9f5effb  libresolv.9.dylib (64) <A244AE4C-00B0-396C-98FF-97FE4DB3DA30> /usr/lib/libresolv.9.dylib
    0x7fffb9fae000 -     0x7fffba0efffb  libsqlite3.dylib (252) <A531C105-64D7-37C0-B999-9320047B71C5> /usr/lib/libsqlite3.dylib
    0x7fffba1e0000 -     0x7fffba1edfff  libxar.1.dylib (354) <AAFCF321-8100-3622-880B-9661DCA35D69> /usr/lib/libxar.1.dylib
    0x7fffba1f1000 -     0x7fffba2e0ffb  libxml2.2.dylib (30.11) <26676155-64CE-323F-B73C-AD77AF5982E8> /usr/lib/libxml2.2.dylib
    0x7fffba2e1000 -     0x7fffba30afff  libxslt.1.dylib (15.8) <FFF5DD45-F544-34B2-BE3C-DB877DC60081> /usr/lib/libxslt.1.dylib
    0x7fffba30b000 -     0x7fffba31cff3  libz.1.dylib (67) <46E3FFA2-4328-327A-8D34-A03E20BFFB8E> /usr/lib/libz.1.dylib
    0x7fffba32b000 -     0x7fffba32fff7  libcache.dylib (79) <84E55656-FDA9-3B29-9E4F-BE31B2C0AA3C> /usr/lib/system/libcache.dylib
    0x7fffba330000 -     0x7fffba33afff  libcommonCrypto.dylib (60092.1.2) <79F738D8-0AD7-3DEA-AF80-E0F8B90B74E3> /usr/lib/system/libcommonCrypto.dylib
    0x7fffba33b000 -     0x7fffba342fff  libcompiler_rt.dylib (62) <486BDE52-81B4-3446-BD72-23977CAE556F> /usr/lib/system/libcompiler_rt.dylib
    0x7fffba343000 -     0x7fffba34bfff  libcopyfile.dylib (138) <0DA49B77-56EC-362D-98FF-FA78CFD986D6> /usr/lib/system/libcopyfile.dylib
    0x7fffba34c000 -     0x7fffba3ceff3  libcorecrypto.dylib (442.1.3) <1CA8B679-810E-3C04-945A-4AC19372CDC7> /usr/lib/system/libcorecrypto.dylib
    0x7fffba3cf000 -     0x7fffba401fff  libdispatch.dylib (703.1.4) <12B1D95B-283D-325D-85AB-29A2FFD36987> /usr/lib/system/libdispatch.dylib
    0x7fffba402000 -     0x7fffba407ff3  libdyld.dylib (421.1) <CDFBDC9C-418C-369D-B433-F64B0630E640> /usr/lib/system/libdyld.dylib
    0x7fffba408000 -     0x7fffba408ffb  libkeymgr.dylib (28) <09CD7CA6-46D2-3A9F-B9F1-7C4CA5CA0D68> /usr/lib/system/libkeymgr.dylib
    0x7fffba409000 -     0x7fffba415ffb  libkxld.dylib (3789.1.32) <48BDBE7F-AAE6-3050-9017-6959051CF16A> /usr/lib/system/libkxld.dylib
    0x7fffba416000 -     0x7fffba416fff  liblaunch.dylib (972.1.5) <DC31FDEA-FD81-335E-BAA8-5A7395D20772> /usr/lib/system/liblaunch.dylib
    0x7fffba417000 -     0x7fffba41cfff  libmacho.dylib (894) <1EAE5ADD-490C-3B1F-9F97-447BA8E0E90F> /usr/lib/system/libmacho.dylib
    0x7fffba41d000 -     0x7fffba41fff3  libquarantine.dylib (85) <78EF62D8-C890-3FC0-937A-C2FD8CEF8992> /usr/lib/system/libquarantine.dylib
    0x7fffba420000 -     0x7fffba421ffb  libremovefile.dylib (45) <C4FC07FF-ED86-382E-B06F-33C34718080C> /usr/lib/system/libremovefile.dylib
    0x7fffba422000 -     0x7fffba43aff7  libsystem_asl.dylib (349.1.1) <F0987490-8427-367F-B302-A05A7D61FEBF> /usr/lib/system/libsystem_asl.dylib
    0x7fffba43b000 -     0x7fffba43bff7  libsystem_blocks.dylib (67) <B8C3701D-5A91-3D35-999D-2DC8D5393525> /usr/lib/system/libsystem_blocks.dylib
    0x7fffba43c000 -     0x7fffba4c9fe7  libsystem_c.dylib (1158.1.2) <5F260836-48E4-3F57-8553-62D2DA228A1F> /usr/lib/system/libsystem_c.dylib
    0x7fffba4ca000 -     0x7fffba4cdffb  libsystem_configuration.dylib (888.1.2) <67BB9D8B-2430-38AD-81A7-F0EC924B2590> /usr/lib/system/libsystem_configuration.dylib
    0x7fffba4ce000 -     0x7fffba4d1fff  libsystem_coreservices.dylib (41.1) <11F22E6C-0DCB-3699-A4F0-C99E301E56E9> /usr/lib/system/libsystem_coreservices.dylib
    0x7fffba4d2000 -     0x7fffba4eaffb  libsystem_coretls.dylib (121.1.1) <8F7E9B12-400D-3276-A9C5-4546B0258554> /usr/lib/system/libsystem_coretls.dylib
    0x7fffba4eb000 -     0x7fffba4f1fff  libsystem_dnssd.dylib (765.1.2) <C5FF2025-C60B-39C6-B205-6BF1BC51D1B3> /usr/lib/system/libsystem_dnssd.dylib
    0x7fffba4f2000 -     0x7fffba51bfff  libsystem_info.dylib (503) <C686B834-5E7D-382C-AF6E-44AB78EE83E2> /usr/lib/system/libsystem_info.dylib
    0x7fffba51c000 -     0x7fffba53eff7  libsystem_kernel.dylib (3789.1.32) <5C68A0D7-C3C9-3E52-B983-EDE9A28AB6FC> /usr/lib/system/libsystem_kernel.dylib
    0x7fffba53f000 -     0x7fffba586fe7  libsystem_m.dylib (3121.4) <E3370D16-EBAA-3C7F-AC56-2D6EAD7DB0A4> /usr/lib/system/libsystem_m.dylib
    0x7fffba587000 -     0x7fffba5a5ff7  libsystem_malloc.dylib (116) <3DD17B88-B7A4-38B9-9E95-AB88E1C3B647> /usr/lib/system/libsystem_malloc.dylib
    0x7fffba5a6000 -     0x7fffba5fcfff  libsystem_network.dylib (856.1.8) <A8973360-956A-33BF-9971-14D59C84E0D1> /usr/lib/system/libsystem_network.dylib
    0x7fffba5fd000 -     0x7fffba606ff3  libsystem_networkextension.dylib (563.1.11) <1C551832-9360-36DD-A7BA-52B55A171720> /usr/lib/system/libsystem_networkextension.dylib
    0x7fffba607000 -     0x7fffba610ffb  libsystem_notify.dylib (165) <AF77D471-6B13-36BA-B144-7E7DDB9DBA9F> /usr/lib/system/libsystem_notify.dylib
    0x7fffba611000 -     0x7fffba619fe7  libsystem_platform.dylib (126.1.2) <884DDF42-3CAE-334A-82CE-965617130FB1> /usr/lib/system/libsystem_platform.dylib
    0x7fffba61a000 -     0x7fffba624fff  libsystem_pthread.dylib (218.1.3) <050AE77B-4F4B-334A-A5BA-CF0D10AF5304> /usr/lib/system/libsystem_pthread.dylib
    0x7fffba625000 -     0x7fffba628fff  libsystem_sandbox.dylib (592.1.3) <90FEF628-316D-3F84-9EF4-F7F510A4FBBB> /usr/lib/system/libsystem_sandbox.dylib
    0x7fffba629000 -     0x7fffba62afff  libsystem_secinit.dylib (24) <A54B8FEF-E792-3C54-8E0B-E80A376662F2> /usr/lib/system/libsystem_secinit.dylib
    0x7fffba62b000 -     0x7fffba632fff  libsystem_symptoms.dylib (532.1.1) <B26F656E-94F9-3834-9B03-51C4FF11D1BF> /usr/lib/system/libsystem_symptoms.dylib
    0x7fffba633000 -     0x7fffba653ff7  libsystem_trace.dylib (518.1.16) <C3CDF7BC-CA3D-34F5-ADF8-46AAAB0B47F8> /usr/lib/system/libsystem_trace.dylib
    0x7fffba654000 -     0x7fffba659ffb  libunwind.dylib (35.3) <9F7C2AD8-A9A7-3DE4-828D-B0F0F166AAA0> /usr/lib/system/libunwind.dylib
    0x7fffba65a000 -     0x7fffba683ff7  libxpc.dylib (972.1.5) <2A901937-48E1-3BF2-83F1-2431156D82B7> /usr/lib/system/libxpc.dylib

External Modification Summary:
  Calls made by other processes targeting this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
  Calls made by this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
  Calls made by all processes on this machine:
    task_for_pid: 477
    thread_create: 0
    thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=201.9M resident=0K(0%) swapped_out_or_unallocated=201.9M(100%)
Writable regions: Total=56.0M written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=56.0M(100%)

                                VIRTUAL   REGION 
REGION TYPE                        SIZE    COUNT (non-coalesced) 
===========                     =======  ======= 
Kernel Alloc Once                    8K        2 
MALLOC                            21.5M       11 
MALLOC guard page                   16K        4 
MALLOC_LARGE (reserved)           5088K        2         reserved VM address space (unallocated)
STACK GUARD                       56.0M       11 
Stack                             12.3M       11 
VM_ALLOCATE                       10.3G      264 
VM_ALLOCATE (reserved)             608K        6         reserved VM address space (unallocated)
__DATA                            9772K      144 
__LINKEDIT                       113.2M       10 
__TEXT                            88.6M      149 
__UNICODE                          556K        2 
mapped file                       51.3M      183 
shared memory                       12K        4 
===========                     =======  ======= 
TOTAL                             10.7G      789 
TOTAL, minus reserved VM space    10.7G      789 

And these kind of lines are found aplenty in the system.log category in Console:

Apr 13 14:33:29 Sierra ReportCrash[634]: Saved crash report for jackett[638] version 0 to /Users/username/Library/Logs/DiagnosticReports/jackett_2019-04-13-143329_Sierra.crash
Apr 13 14:33:39 Sierra com.apple.xpc.launchd[1] (org.user.Jackett): Service only ran for 1 seconds. Pushing respawn out by 9 seconds.

For me, this was a case-sensitivity issue on the filesystem.

There is a collision between the ${jackettdir}/jackett executable and the attempt to create the config folder at ${jackettdir}/Jackett.

To spell it out explicitly:
/usr/local/bin/Jackett/jackett and /usr/local/bin/Jackett/Jackett are the same thing if the filesystem is case insensitive.

When I write code that creates a config folder automatically I use a convention of appending 'Config' or '_config' to make my stuff accidentally-not-break like this.

The default is case-insensitive on a mac so this default config will fail for everyone, it seems. I wonder why there aren't more issues submitted?

I tried looking up a line number for a simple fix but configurationService line 55 points to some boilerplate that reads a .net config and it would take me a lot of .net homework to contribute.

I propose 2 possible fixes:

  • Changed the candidate folder name to 'JackettConfig'
  • Provide a way to specify the config folder name

The first seems simplest since it cares not about case-sensitivity holy wars or the architecture of the rest of the app.

I have the exact issue in my mac. The workaround is that I rename the executable jackett to something else, e.g. runjackett. But the update can't work anymore since it will try to replace the executable and find it is a directory. When can we fix this? In Mac, any other way to get around this issue before the real fix is in?

This works for me now in build v0.11.534.
It creates the folder in ~/.config/Jackett and there aren't any conflicts in there.

confirmed. It works in 0.11.534. Thanks.

FYI there has not been any changes related to how the packages are built since 11.340, and none specifically related to MacOs since 11.332
all the changes since then are adding/updating/removing indexers.

Something must have happened since 507. I tested it yesterday. It did give me this error. Unhandled Exception: System.Exception: Could not create settings directory. The file '/usr/local/bin/Jackett/Jackett' already exists.
at Jackett.Common.Services.ConfigurationService.CreateOrMigrateSettings() in /home/appveyor/projects/jackett/src/Jackett.Common/Services/ConfigurationService.cs:line 55
at Jackett.Server.Program.Main(String[] args) in /home/appveyor/projects/jackett/src/Jackett.Server/Program.cs:line 91
Abort trap: 6

And after I rename the jackett to something else, like runjackett, it worked. Then when I did update, it gave me the same message.

well since the source was not changed, the only other thing I can think of is that something automatically changed during the appveyor build process that creates the packages. all sorts of standard modules and libraries are pulled in that may have included something. @flightlevel may know, if only he was about to take a look and comment.

FYI - there is also a simple manual workaround if anyone out there still has this issue.

The jackett executable allows for a -d flag to force the data folder.
If you can't upgrade or this issue comes back somehow, manually edit the plist in ~/Library/LaunchAgents/org.user.Jackett.plist and add the following to the launch argument:

<string>-d ${jackettdir}/whatever_name_you_care_to</string>

It seems it only happened when you run jackett the first time, even in 534. The way to get around that is to manually create $HOME/.config/Jackett. After that, you can run it through without any problem.

Was this page helpful?
0 / 5 - 0 ratings

Related issues

silverbullettruck2001 picture silverbullettruck2001  路  4Comments

STX2k picture STX2k  路  3Comments

ade05fr picture ade05fr  路  3Comments

zero77 picture zero77  路  4Comments

whitesnakeftw picture whitesnakeftw  路  3Comments